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Setup & Installation 
 

Running the Installer 

 

 
 

 

• Install IVI Shared Components (minimum version 2.6.1) and Visa Shared Components 

(minimum version 5.12.0), which are shipped with the installation media. 

• Ensure the installation PC has .NET framework version 4.7.2 or above installed. 

• Run the .msi installer file which arrived with the installation media. 

• Follow the installation wizard process, which requires selection of an appropriate installation 

location on the PC. 

• After the installation is complete, the application can be launched from the Start Menu or 

desktop and will be called ‘AnaPico Cal Tool v3’. 

 

Connecting Instruments 

• Before launching the tool, the DUT (AnaPico signal generator device) and a supported power 

sensor should be connected via USB to the PC. 

• The power sensor should be connected to the channel of the DUT to be calibrated using the 

manufacturer-specified torque. 

Supported power sensors are listed here: 

• LadyBug LB5940L 

• LadyBug LB5926L 

• LadyBug LB5908L 

• LadyBug LB589A  

Figure 1 - Installation Wizard 
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First Start-Up & Instrument Connections 
 

Validating a License File 

When the tool has been installed for the first time, the user will need to supply a license to 
unlock the modes of operation required. If these were not supplied with the installation 
media, then please contact AnaPico for a license file. 

 

To install a license, click ‘Help’->’Validate License File’ and navigate to where the license file 
is saved – double click it. If valid, the modes of operation the license permits will become 
available. The application will remember the license file after restarting. Keep the original 
license file backed up in a safe place so the application can be installed and licensed on other 
PCs if needed. 

 

Setting a device results directory 

When the tool has been installed for the first time the user will be requested to supply a 
folder in which to export results from the calibration tool. The directory structure is as 
follows: [Root Export Directory] -> ‘Device Type’ -> ‘Device Model’ -> ‘Device Serial Number’ 
-> ‘Channel’. The [Root Export Directory] is the folder which must be selected by the user. 
This directory can be changed later via the Edit menu (see below). 

 

 
 

 

Connecting to a Device 

 

 

Figure 2 - Setting a device results directory path 

Figure 3 - Connect Button & ‘Connections’ menu 
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Select this button to open a new dialog containing a list of available signal generators and 
power sensors to connect to n.b. the power sensor and signal generator must be supported 
by the tool before connection is possible.  

 

The connection dialog can also be accessed from the ‘Connections’ menu. 

 

 
 

 

When selecting a signal generator device, any existing datasets will be loaded and displayed 
within the tool. By default, the latest data will be plotted within each tab, if available (for the 
most recent completed task). 

If a signal generator device is not supported by the tool, this will be indicated within the 
console output when the user tries to connect. 

For the power sensor selection, only supported models will be displayed by the tool. 

A successful connection must be established to both a signal generator device and a power 
sensor before calibration tasks can be run.  

See section ‘Controlling a Calibration Task’ for instructions on how to proceed with 
calibrating your device. 

  

Figure 4 - Device Connections Dialog 
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Application Menus 
 

Help Menu 

Select Help -> About to see details of the version of the calibration tool which is installed, as 
well as details of the currently connected signal generator, including firmware version and 
serial number. 

 

Help -> Validate License – for information on this menu item see section ‘Validating a License 
File’. 

 

 
 

 

Tools Menu 

Tools -> Frequency Tuning Tool – for info. See section ‘Frequency Tuning Tool’. 

 

View Menu 

Select View -> Calibration Results to open the results directory of the currently connected 
device within windows explorer. This directory can also be accessed using the ‘Open 
Calibration Results’ button at the bottom of the window. The results directory shows files 
which have been exported after the completion of a calibration task. 

 

Figure 5 - About Dialog 
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Edit Menu 

Select Edit -> Change Root Export Directory to change the top-level directory where device 
results are exported n.b. this will not migrate existing results from a prior directory – 
migration must be carried out manually by the end user. 

File Menu 

File -> Export Current Plot opens a save dialog to export the currently visible plot to a 
directory and with a file name specified by the user. By default, the file is given a unique 
name with a timestamp which includes the serial number and the current channel of the 
connected signal generator. This option can also be accessed using the button ‘Export 
Current Plot’ at the bottom of the window. Bear in mind, this and other ‘File Menu’ options 
will only work when a signal generator is connected. 

 

File -> Export Local Device Files – this option is only used in cases where results from a 
calibration task could not be exported to the directory specified by the user. In this case 
these files will be backed up temporarily to a local directory. The user should click this option 
when the normal results directory path is again available, and the missing files will be 
exported to the correct location. 

 

File -> Upload Calibration – for details on this menu item, see section ‘Upload Calibration File 
Manually’. 

  



 

 AnaPico Inc.   Europastrasse 9   8152 Glattbrugg   Switzerland   Tel.: +41 44 440 00 50   www.anapico.com        Page 8         

 

Calibration Info. & Visuals 
 

Toolbar 

 

 

 

The toolbar contains peripheral controls which are used alongside a calibration task. Most 
options on the toolbar are available additionally within the application menus. The individual 
controls are explained in more detail below (in order from left to right): 

 

• The ‘Connect’ button is an alternative way to access the ‘Connections’ dialog (see section on 

‘Connect Button’) 

• The channel selection dropdown displays the current channel of the connected signal 

generator being controlled (see section on ‘Channel Selection’) * 

• ‘Export Visible Plot’ saves the visible plot to file - this control will load up a save dialog where 

you can specify a filename and file type to export * 

• ‘Open Device Results Directory’ opens the folder where the calibration results are saved for 

the current device. This only works when a device is connected and calibration tasks have 

previously been run (see section on ‘Device Results Directory’) * 

• ‘Export Missing Files’ will export any results files from calibration tasks which could not be 

saved to the results directory but were backed up locally instead (see ‘File Menu’ section -> 

‘Export Local Device Files’) * 

• ‘Open Calibration Manager’ is a reserved function for AnaPico administrators. 

• ‘Open Frequency Tuning Tool’ opens a separate window with controls for adjusting the 

frequency tuning of the connected device. This option is only available if a device is 

connected and if your license permits (see section on ‘Frequency Tuning Tool’) * 

• ‘Open Power Monitor’ opens a separate window with controls to manually adjust the 

frequency and power output of the device whilst displaying a continuous reading from the 

connected power sensor (see section on ‘Power Monitor Tool’) ** 

• ‘Reload Device Calibration’ refreshes all displayed data within plot tabs for the connected 

device * 

• ‘Browse / Upload Calibration File’ opens a dialog to upload a calibration file to the connected 

device. (See section on ‘Upload Calibration File Manually’) * 

All controls with an asterisk (*) require a device to be connected first. 

Controls with two asterisks (**) require a device and power sensor to be connected first. 

 

 

 

 

Figure 6 - Toolbar Controls 
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Status Bar 

 

 

 

The status bar at the top of the window displays the following information: 

 

• ‘Elapsed Time’ indicates the amount of time passed since the most recent calibration task 

was started and stops upon completion of the task. 

 

• ‘Remaining Time’ gives an approximate indication of the remaining time to complete the 

current Adjustment or Frequency Sweep task. 

 

• ‘Controller Temp’ displays the temperature, in degrees Celsius, of the current connected 

device; this field is blank when a signal generator is not connected to the tool. The 

background will initially display in orange when connected to a device and will remain 

orange until the DUT controller temperature has reached a stable operating temperature, 

at which point it will turn green. 

 

• ‘RF Board Temp’ displays the temperature of the RF board of the selected channel. Its 

availability depends on device firmware version. 

 

• ‘Cal. Points on Device’ indicates the number of calibrated frequencies within the connected 

device’s calibration table. 

 

• ‘Cal. Points Modified’ indicates the number of calibration points which have been modified 

by the tool during an adjustment or refinement task. 

 

• ‘Cal. Points inserted’ shows how many new calibration points have been inserted into the 

device’s calibration table during a refinement task. 

 

• Current frequency and power level show the levels currently being verified, adjusted of 

swept over, depending on the current task being run. These fields should help you track the 

progress of the running task. 

 

• Points checked shows “X/Y”, where X is the number of frequencies which have been 

processed so far in the running task; and Y is the total number of frequencies to be processed 

within the current running task. For a refinement task only, these values indicate the 

progress during each pass, so may be reset several times to different values. 

 

• ‘Base Model Detected’ is for admin users only. 

  

Figure 7 - Status Bar Fields 
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Plot Tabs 

The plot tabs are displayed immediately beneath the status bar and contain the following 
plots: 

 

• ‘External Att.’ shows the power error of the external attenuator stages – this plot is only 

updated during a verification task. 

 

 
 

 

• The ‘Refinement’ plot tab shows the power levels from the device calibration table, during 

and after a refinement task, indicating the error at each power level. This plot also marks 

where new calibration points have been inserted into the device’s calibration table, indicated 

by a yellow diamond. Additionally, where existing calibration points have been corrected or 

Figure 8 - External Attenuator Plot 

Figure 9 - Refinement Plot 
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‘modified’, this is indicated with a blue triangle. Both markers after displayed about ‘0’ on the 

y-axis. 

 

 

 

• ‘Adjustment’ shows the power levels from the device calibration table during and after an 

adjustment task – it indicates power error both before and after adjustment for each power 

level.  

 

Figure 10 - Adjustment Plot 

Figure 11 - Adjustment Plot Context Menu 
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• The user can right-click on the plot when connected to a device and select the plot line filters 

which will show/hide the visible plot lines. To display multiple plot lines the user can hold 

down the ‘Ctrl’ key whilst selecting those to display. These filter options are available on the 

refinement, verification, and freq. sweep tabs also. To remove any filter which has been 

applied, select the ‘Show All Plotlines’ option. 

• Within the context menu of each plot there is also the option to ‘Centre Axes’ which will 

return the current view, so all plotted data is visible. Additionally, there is the ‘Logarithmic 

Scale’ option which will swap between a linear and logarithmic frequency scale for all plots 

simultaneously. 

 

 

• ‘Verification’ shows the power error at each calibrated frequency and power level from the 

device calibration table during and after a verification task. 

 

Figure 12 - Verification Plot 

Figure 13 - Frequency Sweep Plot 
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• ‘Frequency Sweep’ shows the user-specified power levels swept across frequency as 

specified within the running Freq. Sweep task. 
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Controlling a Calibration Task 
 

Control Tabs 

On the bottom-left hand side of the screen is the Control Toolbox which contains one or 
more of the following tabs (depending on license): 

 

Refinement 

 

• Provides controls for running a refinement task. A refinement will first check the existing 

calibration and will adjust at the pre-calibrated frequencies if the power error drops outside 

of the specified tolerance. It will then run one or more passes to check the power error 

between calibrated frequencies. If further calibration is needed at these points, new points 

will be calibrated and inserted into the device’s calibration table. Multiple passes across the 

specified frequency range will occur, until no more frequencies are found where the power 

error is outside the tolerance specified. 

 

The options available to the user on these tabs include: 

o Additional Points – The number of frequencies to check between existing calibration 

points – a higher number indicates a higher resolution check, but will result in a 

longer refinement run.  

o Error Tolerance – Specified in dB – any points discovered outside of this error range 

will be recalibrated or a new point inserted. An allowance is made for measurement 

uncertainty, so occasionally points just within the specified error range will also be 

recalibrated too. 

o Start Freq. – The frequency in MHz to start the task from – the closest frequency less 

than the specified frequency within the calibration table of the device will be used as 

the starting frequency. [By default, the value will be the lowest calibrated frequency] 

o End Freq. – The frequency in MHz to end the task at – the closest frequency greater 

than the specified frequency within the calibration table of the device will be used as 

the starting frequency. [By default, the value will be the highest calibrated frequency] 

 
 

 

 

 

 

Figure 14 - Refinement Control Tab 
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Adjustment / Verification 

 

• These tabs facilitate the running of an adjustment or verification task.  

An adjustment will run through the specified frequency range and recalibrate each power 

level to achieve a reduced error across the range. 

A verification task will run through the specified frequency range and measure the current 

error exactly on each calibrated frequency point. If run before an adjustment task, it will give 

an indication as to whether an adjustment is needed, or if run after an adjustment task, will 

verify if the adjustment was successful. 

 

The options available to the user on these tabs include: 

o Error Tolerance – This value indicates the size of the green tolerance band which is 

visible during the adjustment or verification task; this band is used as a visual aid to 

show how accurate the power output of the device is against the accuracy desired by 

the user. 

o Start Freq. – The frequency in MHz to start the task from – the closest frequency less 

than the specified frequency within the calibration table of the device will be used as 

the starting frequency. [By default, the value will be the lowest calibrated frequency] 

o End Freq. – The frequency in MHz to end the task at – the closest frequency greater 

than the specified frequency within the calibration table of the device will be used as 

the starting frequency. [By default, the value will be the highest calibrated frequency] 

o Start Button begins the requested task – bear in mind that before a task can be 

started, the user must have first connected to a power meter and a signal generator 

device. 

 

 

Frequency Sweep 

 

• This tab allows the user to perform a custom sweep across frequency and power level to 

validate a calibration at custom power and frequency steps.  

 

It has the following available options: 

o Range (MHz) – this indicates the frequency range to sweep over, from the lowest 

frequency to the highest 

Figure 15 - Verification / Adjustment Control Tab 



 

 AnaPico Inc.   Europastrasse 9   8152 Glattbrugg   Switzerland   Tel.: +41 44 440 00 50   www.anapico.com        Page 16         

 

o # Frequencies – indicates the number of frequencies to check within the specified 

range – for example 11 frequencies over a range of 10MHz will yield a step-size of 

1MHz). 

o Frequency Spacing – indicates whether to use a linear spacing of the frequency 

points specified or a logarithmic spacing. 

o Range (dBm) – provides the power range to sweep over, from the lowest power to 

the highest. 

o Step Size (dB) – indicates the power step size which will dictate the actual power 

levels which are used - i.e. a range of -10dBm to 10dBm with a step size of 5dB will 

result in -10, -5, 0, 5 and 10dBm used in the sweep.  

o Error Tolerance – indicates the width of the green tolerance band which is displayed 

on the ‘Freq. Sweep’ plot during the frequency sweep task – this acts as a visual aid 

to help the user monitor the accuracy of different power levels over frequency. 

o Start Button – begins the requested task with specified options. 

 

 

 

 

Channel Selection 

For multi-channel devices, the user can specify the device channel they wish to control by 
changing the selection in the dropdown – this must match the channel the intended power 
sensor is connected to. The selected channel will be the one controlled when tasks are run 
by the user. When switching channels, the plots will refresh to show data relevant to the 
selected channel. If data is not available for a particular device/channel combination, then 
some plots will remain empty. 

 

 

 

  

Figure 16- Frequency Sweep Control Tab 

Figure 17 - Channel Selection 
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Analysing Results 
 

Console Output (bottom-right) 

The console shows information regarding connected devices, status and progress of running 
tasks including any warnings or failure messages if a task could not be completed. Whilst a 
task is running the user may click the console to temporarily freeze the output if they wish to 
read some messages in detail. Clicking the console again will hop back down to the latest 
information. The freezing of the output does not affect any running tasks. 

 

Above the console is also a progress bar, which indicates the status of any calibration tasks 
which are currently running.  

 

 

Device Results Directory 

A device directory is created for each channel of each device when a task is performed on 
that device and channel number. Each of the results directories are created under the root 
results directory which is specified on opening after first installation, and which can be 
changed by the user at any time (see ‘Edit Menu’ section). No sub-directories exist until at 
least one task has been successfully completed by the tool. Successful completion implies 
that the task has fully run from beginning to end without failures. If a failure occurs during a 
run then it is assumed that the integrity of the calibration task is compromised, therefore 
the results are not exported. 

The results directory contains the following information, according to which of the below 
tasks was run: 

Frequency Sweep 

• PNG image showing the plotted sweep results 

• Dataset file (.csv) containing a record of the plotted points within the sweep plot 

• VLOG (text) file holding a detailed log of the frequency sweep task 

Verification 

• PNG image showing the plotted verification results 

• [optional] PNG image showing the External Attenuator verification results (if the signal 

generator has an external attenuator)  

• Dataset file (.csv) containing a record of the plotted points within the verification plot 

Figure 18 - Console Output 
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• [optional] Dataset file (.csv) containing a record of the plotted points within the External Att. 

plot (if the signal generator has an external attenuator) 

• VLOG (text) file holding a detailed log of the verification task 

Adjustment 

• Dataset file (.csv) containing the resultant calibration file which was uploaded to the signal 

generator upon completion of the adjustment task 

• PNG image showing the plotted adjustment results 

• Dataset file (.csv) containing a record of the plotted points within the adjustment plot 

• VLOG (text) file holding a detailed log of the adjustment task 

Refinement 

• Dataset file (.csv) containing the resultant calibration file which was uploaded to the signal 

generator upon completion of the refinement task 

• PNG image showing the plotted refinement results 

• Dataset file (.csv) containing a record of the plotted points within the refinement plot 

• VLOG (text) file holding a detailed log of the refinement task 

 

 

 

Dataset File Export Format 

Exported dataset files entitled “freq_sweep_dataset”, “verification_dataset”, 
“adjustment_dataset” or “refinement_dataset” contain the following information: 

• Column 1 shows the frequency in Hz 

• Column 2 shows the measured relative power error in dB 

• Column 3 shows the power level in dBm and the device power zone (separated by a comma) 

Figure 19 - A typical device results directory 
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Exported dataset files entitled “pe_error” show equivalent information in column 1 and 2, 
but in the 3rd column they show the nominal attenuation of the attenuator being verified (in 
dB). 

 

Automatic Archiving 

When a task completes successfully, the dataset files pertaining to previously completed 
tasks for the connected device (and channel) will be moved to a directory called ‘Archive’ 
within the device’s results directory. The most recent dataset files for the completed task 
will be exported to the device’s results directory. 

 

Frequency Tuning Tool 

The frequency tuning tool is a widget which can be accessed from the ‘Tools’ menu or via the 
toolbar option, only if your installed license permits.  

 

 
 

 

 

The tuning widget allows for the connected device’s frequency to be tuned precisely. Use 
the arrow controls or the slider to tune the frequency – when you are happy with the result 
then click the ‘Save’ button to keep the current setting. If ‘Discard’ is clicked or the widget is 
closed without saving, then the tuning value will not be saved by the signal generator. 

  

Figure 20 - Frequency Tuning Widget 
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Power Monitor Tool 

The Power Monitor tool can be opened from the toolbar by clicking the following icon: 

 

 
 

 

This window allows a custom frequency and power setting to be sent to the device whilst 
displaying a continuous power reading from the power sensor. 

For frequency setting, enter the desired frequency, followed by the units i.e. ‘10’ followed by 
‘h’ for Hz, ‘k’ for kHz, ‘m’ for MHz or ‘g’ for GHz (or omit the units to keep the current unit 
displayed). Press the enter key to send the frequency to the device. 

 

For the power setting, type the desired power in dBm and then press the enter key to send 
the power to the device. 

 

The up and down arrow buttons can be used to finely adjust the frequency or power 
settings. The step-size is governed by the ‘Step’ setting next to each control. The 
corresponding setting will be sent to the device immediately with each click. 

  

Figure 21 - Power Monitor Tool 
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Upload Calibration File Manually 

Within the file menu, the option ‘Upload Calibration’ (or via the toolbar button) allows for a 
calibration file of choice to be uploaded to the connected signal generator. By default, an 
‘open file’ dialog will open with the results directory of the connected device. Within the 
‘Archive’ directory for a given device, an older calibration may be uploaded to revert the 
device back to a previous calibration. 

When an adjustment or refinement task is run on a device, before starting, the current 
device calibration will be saved within the respective device’s ‘Archive’ directory (for the 
channel being adjusted). These files are entitled ‘calibration_backup’, followed by the device 
serial number and a timestamp indicating when the file was created. It is possible to use the 
‘Upload Calibration’ function to revert to one of these backed up device calibrations, for 
example, if the user is unhappy with the output of an adjustment. 

 

 
 

 
Figure 22 - Calibration File Upload Dialog 


